?
  • 489 评论(2) 2017-12-01 15:23:57
一、实验要求

1、手动汇总

2、链路认证

3、设置默认路由

4、修改COST

5、修改AD

6、R1过滤23.1.1.0/24,并ping192.168.1.1

二、实验分析

1、网络拓扑图

2、IP地址规划表

ip地址规划表

设备属性

设备名称

Route-id

设备接口

设备ip地址

R1

1.1.1.1

e0/0

12.1.1.1/24

loopback 0

10.10.1.1/24

loopback 1

10.10.2.1/24

loopback 1

10.10.3.1/24

R2

2.2.2.2

e0/0

12.1.1.2/24

e0/1

23.1.1.2/24

loopback0

9.9.9.9/24

R3

3.3.3.3

e0/0

34.1.1.3/24

e0/1

23.1.1.3/24

e0/2

35.1.1.3/24

R4

4.4.4.4

e0/0

34.1.1.4/24

loopback0

100.1.1.1/24

loopback1

192.168.1.1/24

R5

e0/2

35.1.1.5/24

loopback 0

172.16.1.1/24

loopback 1

172.16.2.1/24

loopback 2

172.16.3.1/24

三、实验步骤

3.1 基本配置

R1基本配置及路由配置

hostname R1

!

interface Loopback0

ip address 10.1.1.1 255.255.255.0

!

interface Loopback1

ip address 10.1.2.1 255.255.255.0

!

interface Loopback2

ip address 10.1.3.1 255.255.255.0

!

interface Ethernet0/0

ip address 12.1.1.1 255.255.255.0

!

router ospf 1

log-adjacency-changes

network 10.1.0.0 0.0.255.255 area 1

network 12.1.1.0 0.0.0.255 area 1

R2基本配置和路由配置

interface Loopback0

ip address 9.9.9.9 255.255.255.0

!

interface Ethernet0/0

ip address 12.1.1.2 255.255.255.0

ip ospf 1 area 1

!

interface Ethernet0/1

ip address 23.1.1.2 255.255.255.0

ip ospf 1 area 0

!

router ospf 1

router-id 2.2.2.2

log-adjacency-changes

network 9.9.9.0 0.0.0.255 area 1

!

R3基本配置及路由配置

interface Ethernet0/0

ip address 34.1.1.3 255.255.255.0

ip ospf 1 area 2

!

interface Ethernet0/1

ip address 23.1.1.3 255.255.255.0

ip ospf 1 area 0

!

interface Ethernet0/2

ip address 35.1.1.3 255.255.255.0

!

router ospf 1

router-id 3.3.3.3

log-adjacency-changes

redistribute rip subnets

!

router rip

version 2

network 35.0.0.0

redistribute ospf 1 metric 2

no auto-summary

R4基本配置和路由配置

interface Loopback0

ip address 100.1.1.1 255.255.255.0

!

interface Loopback1

ip address 192.168.1.1 255.255.255.0

!

interface Ethernet0/0

ip address 34.1.1.4 255.255.255.0

!

router ospf 1

log-adjacency-changes

network 34.1.1.0 0.0.0.255 area 2

R5基本配置和路由配置

interface Loopback0

ip address 172.16.1.1 255.255.255.0

!

interface Loopback1

ip address 172.16.2.1 255.255.255.0

!

interface Loopback2

ip address 172.16.3.1 255.255.255.0

!

interface Ethernet0/2

ip address 35.1.1.5 255.255.255.0

!

router rip

version 2

network 35.0.0.0

network 172.16.0.0

no auto-summary

!

3.2 手动汇总

3.2.1 区域间汇总

OSPF手动汇总只能在ABR 上设置

汇总前

汇总命令在ABR上进行设置,在R2上配置命令

router ospf 1

area 1 range 10.1.0.0 255.255.0.0

汇总后

3.2.2 外部路由汇总

外部路由必须在ASBR上进行汇总。

汇总前

在本拓扑图中的ASBR 中设置,R3

router ospf 1

summary-address 172.16.0.0 255.255.0.0

汇总后


3.3.3 利用静态路由进行汇总再重分发

不能够同时使用动态和静态路由,优先使用静态路由

ip route 10.1.0.0 255.255.0.0 null 0 意思是所有数据包丢失

汇总前

在R1上配置ip route 10.1.0.0 255.255.0.0 null 0

router ospf 1

redistribute static subnets

3.3 链路认证

连线两端口都要设置

R1上配置

inter e0/0

ip ospf authentication message-digest

ip ospf message-digest-key 1 md5 ccnaccna 为密码)

配置完之后,只有一方设置认证,显示邻居关系断开

当双方都设置认证后,断开其中一个端口

ip ospf authentication message-digest 使用MD5认证

ip ospf authentication 明文认证

ip ospf authentication null 区域间需要认证,则虚拟必须认证;不想对虚拟进行认证的话 ,使用null进行声明


3.4 默认路由

R4上配置虚拟接口100.1.1.1/24不写入ospf路由的话,R1无法ping100.1.1.1

R4上配置

router ospf 1

default-information originate always (给ospf注入默认路由)

router ospf 1

default-information originate

ip route 0.0.0.0 0.0.0.0 null 0

之后则可以ping

有无always的区别在于是否设置要多设置一条静态默认路由

3.5 修改COST

cisco中回还接口的带宽cost值为小数,默认为1。华为或华三等设备直接忽略该数值

修改cost仅用于选路,与数据传输速度无关

修改cost值之前

R1上查看各个路由的cost

在R1 e0/0口修改cost值后

inter e0/0

ip ospf cost 50

3.6 修改 AD(默认值110

3.6.1 直接修改AD

R1上设置

router ospf 1

distance ospf exter 100 inter-area 99 intra-area 88

其中external代表外部路由,重分发的,O E2 ;inter-area:区域间 O IA

inter-area:区域内, O

3.6.2 针对某一条路由

R1R29.9.9.9/24

管理距离均为110

R1上设置

access-list 1 permit 9.9.9.0 0.0.0.255

router ospf 1

distance 97 2.2.2.2 0.0.0.0 1

问题:使用上述命令可以对O(区域内路由修改AD值)

且,同时只能对一条路由进行修改,换一条路由进行修改,则原修改的路由AD值恢复默认的110

3.7 R1过滤23.1.1.0/24

R1上配置

access-list 11 deny 23.1.1.0 0.0.0.255

access-list 11 permit any

distribute-list 11 in e0/0

R1上查看不到23.1.1.0/24的路由条目

但依然可以ping192.168.1.1


文明上网理性发言评论 您还可以输入:/200个字

全部评论(2)

xy 2017-12-07 14:08:12

可以总结一下使用感想

好好干 2017-12-05 10:50:10

emmm 加油

第 1 页/共 1 页 (10 条/页 共 2 条)

技术分享排行榜

热门课程推荐

  • Python开发管理VCenter

    0 阅读

  • 红帽认证 RHCSA 题库实验

    372 阅读

  • Cisco-OSPF协议

    268 阅读

  • VPN技术配置管理(Cisco)

    47 阅读

  • IPV6协议配置详解(Cisco)

    24 阅读

  • SUSE NCLA_11入门基础(上)

    123 阅读

美女丝袜操屄视频,非洲一级特黄大片大全,性爱小视频免费网址,天堂av 国产av,av27成年电影