?

一、实验要求

1、整个实验包含5台路由器(R1 R2 R3 R4 R5)

2、全网采用RIP动态路由,并保证连通性。

3、要求RIP自动汇总和手动汇总

4、在R4上设置被动接口

5、在R4与R5之间启动单播更新

6、R1将数据包传输给R5走R2这条路由

二、实验分析

      1、 网络拓扑图

2ip地址规划表

ip地址规划表

设备名称

设备接口

设备ip地址

R1

G0/0

12.1.1.1/24

G0/1

13.1.1.1/24

Loop0

172.16.4.1/24

Loop1

172.16.5.1/24

Loop2

172.16.6.1/24

R2

G0/0

12.1.1.2/24

G0/2

24.1.1.2/24

R3

G0/0

34.1.1.3/24

G0/1

13.1.1.3/24

R4

G0/0

34.1.1.4/24

G0/1

45.1.1.4/24

G0/2

24.1.1.4/24

R5

G0/1

45.1.1.5/24

Loop0

172.16.0.1/24

Loop1

172.16.1.1/24

Loop2

172.16.2.1/24

Loop3

172.16.3.1/24

 

三、实验步骤

1、网络的基本配置

       1.R1端口设置ip地址并启动端口

R1>en

R1#conf t

R1(config)#int e0/0(进入e0/0

R1(config-if)#ip add

R1(config-if)#ip address 12.1.1.1 255.255.255.0(给e0/0口设置ip地址

R1(config-if)#no sh(启动该端口

R1(config-if)#int e0/1(进入e0/1

R1(config-if)#ip add

R1(config-if)#ip address 13.1.1.1 255.255.255.0(给e0/1口设置ip地址

R1(config-if)#no sh(启动该端口

       2.R2端口设置ip地址并启动端口

R2>en

R2#conf t

R2(config)#int e0/0(进入e0/0

R2(config-if)#ip add

R2(config-if)#ip address 12.1.1.2 255.255.255.0(给e0/0口设置ip地址

R2(config-if)#no sh(启动该端口

R2(config-if)#int e0/2(进入e0/2

R2(config-if)#ip add

R2(config-if)#ip address 24.1.1.2 255.255.255.0(给e0/2口设置ip地址

R2(config-if)#no sh(启动该端口

       3.R3端口设置ip地址并启动端口

R3>en

R3#conf t

R3(config)#int e0/0(进入e0/0

R3(config-if)#ip add

R3(config-if)#ip address 34.1.1.3 255.255.255.0(给e0/0口设置ip地址

R3(config-if)#no sh(启动该端口

R3(config-if)#int e0/1(进入e0/1

R3(config-if)#ip add

R3(config-if)#ip address 13.1.1.3 255.255.255.0(给e0/1口设置ip地址

R3(config-if)#no sh(启动该端口

       4.R4端口设置ip地址并启动端口

R4>en

R4#conf t

R4(config)#int e0/0(进入e0/0

R4(config-if)#ip add

R4(config-if)#ip address 34.1.1.4 255.255.255.0(给e0/0口设置ip地址

R4(config-if)#no sh(启动该端口

R4(config-if)#int e0/1(进入e0/1

R4(config-if)#ip add

R4(config-if)#ip address 45.1.1.4 255.255.255.0(给e0/1口设置ip地址

R4(config-if)#no sh(启动该端口

R4(config-if)#int e0/2(进入e0/2

R4(config-if)#ip add

R4(config-if)#ip address 24.1.1.4 255.255.255.0(给e0/2口设置ip地址

R4(config-if)#no sh(启动该端口

       5.R5端口设置ip地址并启动端口

R5>en

R5#conf t

R5(config)#int e0/1(进入e0/1

R5(config-if)#ip add

R5(config-if)#ip address 45.1.1.5 255.255.255.0(给e0/1口设置ip地址

R5(config-if)#no sh(启动该端口

2、动态路由配置

       1.R1使用RIP启动动态路由

R1#conf t

R1(config)#router rip(启动动态路由命令

R1(config-router)#version  2RIP版本

R1(config-router)#network 12.1.1.0(启动该网段动态路由

R1(config-router)#network 13.1.1.0(启动该网段动态路由

       2.R2使用RIP启动动态路由

R2#conf t

R2config)#router rip(启动动态路由命令

R2(config-router)#version  2RIP版本

R2(config-router)#network 12.1.1.0(启动该网段动态路由

R2(config-router)#network 24.1.1.0(启动该网段动态路由

       3.R3使用RIP启动动态路由

R3#conf t

R3(config)#router rip(启动动态路由命令

R3(config-router)#version  2RIP版本

R3(config-router)#network 34.1.1.0(启动该网段动态路由

R3(config-router)#network 13.1.1.0(启动该网段动态路由

       4.R4使用RIP启动动态路由

R4#conf t

R4(config)#router rip(启动动态路由命令

R4(config-router)#version  2RIP版本

R4(config-router)#network 24.1.1.0(启动该网段动态路由

R4(config-router)#network 34.1.1.0(启动该网段动态路由

R4(config-router)#network 45.1.1.0(启动该网段动态路由

       5.R5使用RIP启动动态路由

R5#conf t

R5(config)#router rip(启动动态路由命令

R5(config-router)#version  2RIP版本

R5(config-router)#network 45.1.1.0(启动该网段动态路由

3、自动汇总配置

       1.R5设置4loopback地址

R5#conf t

R5(config)#int loopback 0(进入loopback 0

R5(config-if)#ip address 172.16.0.1 255.255.255.0(设置地址

R5(config-if)#int loopback 1(进入loopback 1

R5(config-if)#ip address 172.16.1.1 255.255.255.0(设置地址

R5(config-if)#int loopback 2(进入loopback 2

R5(config-if)#ip address 172.16.2.1 255.255.255.0(设置地址

R5(config-if)#int loopback 3(进入loopback 3

R5(config-if)#ip address 172.16.3.1 255.255.255.0(设置地址

       2.R5上配置动态路由

R5(config)#router rip

R5(config-router)#version 2

R5(config-router)#network 172.16.0.0(配置动态路由

       3.R1上查看

R1#sh ip route(查看路由表

R     24.0.0.0/8 [120/1] via 12.1.1.2, 00:00:03, Ethernet0/0

R     34.0.0.0/8 [120/1] via 13.1.1.3, 00:00:20, Ethernet0/1

R     45.0.0.0/8 [120/2] via 13.1.1.3, 00:00:20, Ethernet0/1

                 [120/2] via 12.1.1.2, 00:00:03, Ethernet0/0

R     172.16.0.0/16 [120/3] via 13.1.1.3, 00:00:20, Ethernet0/1

                    [120/3] via 12.1.1.2, 00:00:03, Ethernet0/0

我们本来写了四条路由 ,现在我们只有一条,我们就是用一条配四条,减少路由表的路由条数。

4、手动汇总配置

       我们不要将自动汇总的删除

       1.R1上配置3loopback地址

R1#conf t

R1(config)#int loopback 0(进入loopback 0

R1(config-if)#ip address 172.16.4.1 255.255.255.0(设置地址

R1(config-if)#int loopback 1(进入loopback 1

R1(config-if)#ip address 172.16.5.1 255.255.255.0(设置地址

R1(config-if)#int loopback 2进入loopback 2

R1(config-if)#ip address 172.16.6.1 255.255.255.0(设置地址

       2.R1上配置动态路由

R1(config)#router rip

R1(config-router)#version 2

R1(config-router)#network 172.16.0.0(配置动态路由

       3.R1R2R3R4R5关闭自动汇总

R1(config)#router rip

R1(config-router)#no auto-summary(关闭自动汇总

       4.R1R5上的端口配上手动汇总

R5(config)#int e0/1(进入端口

R5(config-if)#ip summary-address rip 172.16.0.0 255.255.252.0(设置手动汇总

R1(config)#int e0/0(进入端口

R1(config-if)#ip summary-address rip 172.16.4.0 255.255.252.0(设置手动汇总

R1(config)#int e0/1(进入端口

R1(config-if)#ip summary-address rip 172.16.4.0 255.255.252.0(设置手动汇总

       5.在别的路由器上查看

R2#sh ip route(查看路由表

R        172.16.0.0/22 [120/2] via 24.1.1.4, 00:00:07, Ethernet0/2

R        172.16.4.0/22 [120/1] via 12.1.1.1, 00:00:03, Ethernet0/0

我们发现手动汇总成功了


5、被动接口的配置

      1.R4e0/1口改为被动接口

R4(config)#router rip

R4(config-router)#passive-interface e0/1(将e0/1设置为被动接口

6、启动单播更新

       1.R4e0/1口改为被动接口

R4(config)#router rip

R4(config-router)#passive-interface e0/1(将e0/1设置为被动接口

       2. R4上设置单播更新

R4(config)#router rip

R4(config-router)#neighbor 45.1.1.5

7R1R5优先启用R2这条路线


四、实验总结

  这个实验告诉我们一些在平常路由中的知识。在平常的路由中的汇总,会使平常的路由表条目清晰。还有静态路由和动态路由的结合。路由器的更新。

文明上网理性发言评论 您还可以输入:/200个字

全部评论(1)

好好干 2017-12-05 10:52:22

干巴爹滴斯

第 1 页/共 1 页 (10 条/页 共 1 条)

技术分享排行榜

热门课程推荐

  • Python开发管理VCenter

    0 阅读

  • 红帽认证 RHCSA 题库实验

    372 阅读

  • Cisco-OSPF协议

    268 阅读

  • VPN技术配置管理(Cisco)

    47 阅读

  • IPV6协议配置详解(Cisco)

    24 阅读

  • SUSE NCLA_11入门基础(上)

    123 阅读

美女丝袜操屄视频,非洲一级特黄大片大全,性爱小视频免费网址,天堂av 国产av,av27成年电影